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1 Introduction 

GFI WebMonitor is a comprehensive monitoring solution that enables 
you to monitor and filter network users‟ web traffic (browsing and file 
downloads) in real-time. It also enables you to block web connections 
in progress as well as to scan traffic for viruses, trojans, spyware and 
phishing material. 

It is the ideal solution to transparently and seamlessly exercise a 
substantial degree of control over your network users‟ browsing and 
downloading habits. At the same time, it enables you to ensure legal 
and best practice initiatives without alienating your network users. 

1.1  About this manual 

The aim of this manual is to help you use and configure GFI 
WebMonitor on your network. 

This manual is structured as follows: 

Chapter 1 Introduces this manual and its use. 

Chapter 2 How to access and use GFI WebMonitor‟s dashboard. 

Chapter 3 How to monitor Internet activity. 

Chapter 4 How to configure allowed and blocked entities. 

Chapter 5 How to configure WebFilter Edition policies. 

Chapter 6 How to configure WebSecurity Edition policies. 

Chapter 7 How to configure GFI WebMonitor settings. 

Chapter 8 How to configure and manage quarantined items. 

Chapter 9 Provides information on topics that do not strictly fall 
within other chapters. 

Chapter 10 Provides troubleshooting information on common issues. 

Glossary Explains specific technical terms used in this manual. 

Getting Started Guide 

Detailed installation guidelines are provided in the Getting Started 
Guide, which is downloadable from the GFI website: 

http://www.gfi.com/products/gfi-webmonitor/manual 

The Getting Started Guide provides detailed information on how to 
select your deployment environment and install GFI WebMonitor with 
default settings. 

1.2  Terms used in this manual 

The following terms are used in this manual: 

“NOTE:” 

o Provides additional information and references essential for 
the operation of GFI WebMonitor. 

“IMPORTANT:” 
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o Provides important information such as warnings and 
cautions regarding potential issues commonly 
encountered. 

For any technical terms and their definitions as used in this manual, 
refer to the Glossary chapter in this manual. 
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2 Using the GFI WebMonitor 
dashboard 

2.1  Introduction 

The Dashboard node enables you to obtain graphical and statistical 
information related to GFI WebMonitor‟s operation. This includes: 

 Usage and operations statistics 

 Hits over time and bandwidth usage trend charts 

 WebFilter statistics 

 Last blocked requests and security threats. 

2.2  The GFI WebMonitor dashboard 

 
Screenshot 1 - Dashboard view 
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The Dashboard node in the navigation bar allows you to access the 
GFI WebMonitor Dashboard. The dashboard shows the information 
described in the sections below. 

All graphical and statistical information within the Dashboard node 
displays browsing information for past dates and the current day (from 
midnight to the instant the dashboard is launched). 

NOTE: Click the refresh button  at the upper right corner to refresh 
the displayed information. 

Statistics 

 
Screenshot 2 - Dashboard: Statistics 

The information provided in this table lists a number of important 
operational elements of GFI WebMonitor for the current day (from 
midnight to the instant the dashboard is launched). 

Select the hyperlink next to Current Active Connections to view the 
Active Connections, which are also accessible from the Monitoring 
node. For more information, refer to the Active Connections section in 
the Monitoring Internet activity chapter. 

Select the hyperlink next to Current items in Quarantine to view a 
summary of the quarantine folder. Quarantined items can also be 
accessed from the Quarantine node. For more information, refer to 
the Viewing quarantined items section in the Quarantine chapter. 

AV Scanned Downloads represents the total downloads scanned by 
the anti-virus engines. For more information, refer to the section Virus 
& Spyware Protection in the WebSecurity Edition - File scanning and 
download control chapter. 

Select the other hyperlinks within the Quarantined and Blocked 
section to view further detail on the statistics as summarized below. 

 
Feature Quarantined Blocked 

AV & 

Anti-Phishing 

Selecting the hyperlink 
under Quarantined allows 

you to approve or delete 
quarantined items in the 
Virus Scanning Policies 

category. 

For more information, refer 
to the Viewing quarantined 
items section in the 
Quarantine chapter. 

Selecting the hyperlink 
under Blocked allows you 
to view the Top Policy 
Breakers Report. 

For more information, refer 
to the Top Policy Breakers 
section in the Monitoring 
Internet activity chapter. 
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Download & IM Selecting the hyperlink 
under Quarantined allows 

you to approve or delete 
quarantined items in the 
Download Control 
Policies category. 

For more information, refer 
to the Viewing quarantined 
items section in the 
Quarantine chapter. 

Selecting the hyperlink 
under Blocked allows you 
to view the Top Policy 
Breakers Report. 

For more information, refer 
to the Top Policy Breakers 
section in the Monitoring 
Internet activity chapter. 

Web Filtering Selecting the hyperlink 
under Quarantined allows 

you to approve or delete 
quarantined items in the 
Web Filtering Policies 

category. 

For more information, refer 
to the Viewing quarantined 
items section in the 
Quarantine chapter. 

Selecting the hyperlink 
under Blocked allows you 
to view the Top Policy 
Breakers Report. 

For more information, refer 
to the Top Policy Breakers 
section in the Monitoring 
Internet activity chapter. 

WebSecurity/WebFilter status and usage chart 

 
Screenshot 3 - Dashboard: WebSecurity and WebFilter status and usage chart 

The WebSecurity/WebFilter status and usage chart enables you to: 

 Know whether the WebSecurity and WebFilter components are 
active or not. 

 View a graphical representation of the correlation between the 
number of hits and bandwidth use for the current day (from 
midnight to the instant the dashboard is launched). 

Hits Over Time chart 

 
Screenshot 4 - Dashboard: Hits Over Time chart 

The Hits Over Time chart is a graphical representation of the total 
number of hits per day over the last 30-day period and includes the 
current day (from midnight to the instant the dashboard is launched). 
This enables you to identify a pattern of how website hits fluctuate on 
a day-by-day basis and to identify any anomalies. 
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Bandwidth Usage Trends chart 

 
Screenshot 5 - Dashboard: Bandwidth Usage Trends chart 

The Bandwidth Usage Trends chart is a graphical representation of 
the total bandwidth use per day over the last 30-day period and 
includes the current day (from midnight to the instant the dashboard is 
launched). This enables you to identify patterns and trends of how 
bandwidth is utilized on a day-by-day basis and to identify spikes and 
anomalies. 

Top Categories (Sites) chart 

 
Screenshot 6 - Dashboard: Top Categories (Sites) chart 

The Top Categories (Sites) chart is a graphical representation of the 
top hits (HTTP requests) split by categories for the current day (from 
midnight to the instant the dashboard is launched). This enables you 
to gain knowledge on which categories of sites are being visited by 
web users. 

Top Categories (Bandwidth) chart 

 
Screenshot 7 - Dashboard: Top Categories (Bandwidth) chart 

The Top Categories (Bandwidth) chart is a graphical representation 
of the bandwidth usage split by categories for the current day (from 
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midnight to the instant the dashboard is launched). This enables you 
to identify how your bandwidth is being utilized vis-à-vis the website 
categories browsed by users. 

Top Blocked Categories (Hits) chart 

 
Screenshot 8 - Dashboard: Top Blocked Categories (Hits) chart 

The Top Blocked Categories (Hits) chart is a graphical 
representation of the blocked HTTP requests for the current day (from 
midnight to the instant the dashboard is launched). This enables you 
to identify the main reasons of why requests were blocked. 

Last Blocked Requests list 

 
Screenshot 9 - Dashboard: Last Blocked Requests list 

The Last Blocked Requests list displays the most recent five entries 
for the current day (from midnight to the instant the dashboard is 
launched) of users/IP addresses whose requests were blocked. This 
enables you to identify problems with blocked requests regardless of 
whether these blocked requests are reported to you or not. 

Last Blocked Security Threats list 

 
Screenshot 10 - Dashboard: Last Blocked Security Threats list 

The Last Blocked Security Threats list displays the most recent five 
entries for the current day (from midnight to the instant the dashboard 
is launched) of users/IP addresses from whose machines GFI 
WebMonitor detected the threats/viruses. This enables you to identify 
security issues as early as possible, in time to take preventive 
measures before your network security is breached. 
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3 Monitoring Internet activity 

3.1  Introduction 

The Monitoring node and its sub-nodes enable you to examine 
current and historical web request data processed by GFI 
WebMonitor. Through these nodes, you can view data related to: 

 Active Connections 

 Past Connections 

 Hidden Downloads 

 Search 

 Bandwidth Consumption 

 Sites History 

 Users History 

 Activity Log 

3.2  Active Connections 

The Active Connections report provides information related to 
current active connections. 

 
Screenshot 11 - Monitoring: Active Connections view 

Navigate to Monitoring ► Active Connections to access the Active 
Connections view. 

The information displayed includes: 

 User - the user that is being monitored and whose request is being 
processed at the instant the report is launched or refreshed 

 IP - the IP that is being monitored and whose request is being 
processed at the instant the report is launched or refreshed 

 Bytes - the size of the download at the instant the report is 
launched or refreshed 

 Status - the status of the connection (e.g. Connecting or 
Receiving) at the instant the report is launched or refreshed 

 URL - the URL of the request that is currently being processed 

Further Information 

Click the  button in the Status column of the related connection to 
terminate the download (e.g. interrupt file downloads that are taking 
up too much bandwidth). 
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3.3  Past Connections 

The Past Connections report shows the last 2000 complete 
connections processed by GFI WebMonitor. 

 
Screenshot 12 - Monitoring: Past Connections view 

Navigate to Monitoring ► Past Connections to access the Past 
Connections view. 

The information displayed includes: 

 User - the user that is being monitored and whose request was 
processed 

 IP - the IP that is being monitored and whose request was 
processed 

 Time - the time the request was processed 

 Size - the total size of request that was processed 

 Status - the final status of the connection (e.g. the file type, the 
error code, redirection or not modified) that was processed 

 URL - the URL of the request that was processed 

Table Sorting 

The list is sorted by Time in descending order. 

3.4  Hidden Downloads 

The Hidden Downloads report allows you to monitor all unattended 
downloads from user machines. An unattended download can be one 
of the following: 

 Valid updates started automatically from the user‟s machine 

 Unwanted downloads by hidden applications 

 Interrupted / forgotten downloads initialized by the user. These are 
downloads that are started by the user and not saved within 15 
minutes 

 Malicious downloads that will take advantage of computer software 
vulnerabilities using sequences of commands. 
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Screenshot 13 - Monitoring: Hidden Downloads view 

Navigate to Monitoring ► Hidden Downloads to access the Hidden 
Downloads view. 

The information displayed includes: 

 Last Time - if the URL radio button is selected, the last time when 
the same URL was accessed is displayed. However, if the User 
Agent radio button is selected then the last time when the same 
user agent was used is displayed. 

 Count - the number of times the hidden download was accessed 

 Real Filetype - the file type of a hidden download 

 Content Type - the content type of the hidden download as 
suggested from the web content-type. For more information, refer 
to the Adding New Content-types section in the WebSecurity 
Edition - File scanning and download control chapter. 

 URL - the URL of the downloaded file 

Expand an entry to view the details for the number of times the hidden 
download was accessed. The information displayed includes: 

 Time - the date and time the Hidden download was accessed 

 User - the user that is being monitored and on whose machine the 
hidden download was launched 

 IP - the IP that is being monitored and on whose machine the 
hidden download was launched 

 Size - the size of the downloaded file 

 User Agent - the application/agent that launched the hidden 
download 

From the Group By radio buttons select one of the following display 
options: 

 URL to show the URL of the downloaded file. 

 User Agent to display the agent that started the hidden download. 

 IP to display the IP address of the URL that started the hidden 
download. 

From the Display radio buttons select one of the following options: 

 All to display entries for all file types. 

 Only Executables and Packages to display entries for 
executables and packages only. 
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Further Information 

Select the URL hyperlink to view the Permanent Whitelist dialog. For 
more information, refer to the Add hidden downloads to Whitelist 
section in this chapter. 

3.4.1 Add hidden downloads to Whitelist 

 
Screenshot 14 - Whitelist hidden downloads dialog 

Click the URL of a hidden download to launch the Permanent 
Whitelist dialog. Then click Add to whitelist the selected URL. 

3.5  Search 

The Search node enables you to search through the browsing history 
for a specific date for: 

 a specific site or domain, or a specific category, or 

 a specific user, or 

 a combination of both, or 

 all categories and all users. 
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Screenshot 15 - Monitoring: Search view 

To search an item: 

1. Navigate to Monitoring ► Search to access the Search view. 

2. From the Search By drop-down list, key in the Site or select the 
Category required. 

3. From the User/IP drop-down list, key in or select the User or IP 
address. 

NOTE: When keying in a User in the related search text box, specify 
the username in the format DOMAIN\user. 

4. Specify the date required and click Search to open the Search 
Results for… view. 

The information displayed within the Search Results for… view 
depends on the search criteria specified: 

Site only Displays all the websites belonging to the specified URL or 
domain, visited by all users on the specified date. 

Category only Displays all the websites belonging to the specified category, 
visited by all users on the specified date. 

User only Displays all the websites, visited by the specified user on the 
specified date. 

Site and User Displays all the websites belonging to the specified URL or 
domain, visited by the specified user on the specified date. 

Category and 
User 

Displays all the websites belonging the specified category, 
visited by the specified user on the specified date. 

All Categories 
and Any User 

Displays all the categories visited by all users on the specified 
date. 

Depending on the search criteria specified, the information displayed 
includes: 

 Show Traffic Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Show IM Messages Over Time Chart - for more information, 
refer to the Charts section in this chapter. 
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 Bandwidth (DL/UL) - the total bandwidth used by each site or by 
each web category 

 File Types - the types of files accessed from each site followed by 
the number of times each file type was accessed in brackets 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user. 

 Number of Sites - the number of sites that were accessed by the 
users, which form part of the category 

 Number of Users - the number of users that accessed the sites 
which form part of the category 

 Site - the site that was accessed by the user 

 Usage (DL/UL) - the total bandwidth used by each user 

 User/IP - the user/IP that is being monitored 

 Web Category - the classification of which the accessed site 
forms part of 

3.6  Bandwidth Consumption 

The Bandwidth Consumption reports allows you to monitor 
bandwidth usage. Three types of reports are available: 

 Top Sites 

 Top Users 

 Top Categories 

3.6.1 Top Sites 

The Top Sites report displays the amount of bandwidth consumed by 
visited websites on a specific date. 

 
Screenshot 16 - Bandwidth Consumption: Top Sites report 

Navigate to Monitoring ► Bandwidth Consumption ► Top Sites to 
access the Top Sites report. 

The information displayed includes: 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 
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 Group by Domains - (in the Display Filters group) when selected 
the list is grouped by website-visited domain. 

 Hide Referrals - (in the Display Filters group) when selected the 
list displays only the URLs of the sites which most likely were 
entered manually by the user. 

 Bandwidth (DL/UL) - the total bandwidth used by each site 

 Site - the site that was accessed by the users 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user 

 Web Category - the classification of which the accessed site 
forms part of 

Table Sorting 

By default, the lists are sorted by Bandwidth in descending order, but 
all columns can be sorted in either ascending or descending order by 
clicking on the appropriate column heading. 

Further Information 

Select the Site hyperlink to view the Site Access History. For more 
information, refer to the Site Access History section in this chapter. 

3.6.2 Top Users 

The Top Users report displays the amount of bandwidth consumed by 
users/IP addresses on a specific date. 

 
Screenshot 17 - Bandwidth Consumption: Top Users report 

Navigate to Monitoring ► Bandwidth Consumption ► Top Users 
to access the Top Users report. 

The information displayed includes: 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 User/IP - the user/IP that is being monitored 

 Usage (DL/UL) - the total bandwidth used by each user 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user 

 Sites Accessed - the total number and names of different sites 
accessed by the user 

Table Sorting 

By default, the list is sorted by Usage (DL/UL) in descending order, 
but all columns apart from Sites Accessed can be sorted in either 
ascending or descending order by clicking on the appropriate column 
heading. 
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Further Information 

Select the User/IP hyperlink to view the User History Details. For 
more information, refer to the User History Details section in this 
chapter. 

3.6.3 Top Categories 

The Top Categories report displays the amount of bandwidth 
consumed by categories of visited websites on a specific date. 

 
Screenshot 18 - Bandwidth Consumption: Top Categories report 

Navigate to Monitoring ► Bandwidth Consumption ► Top 
Categories to access the Top Categories report. 

The information displayed includes: 

 Bandwidth (DL/UL) - the total bandwidth used by each web 
category 

 Web Category - the classification of which the accessed sites 
form part of 

 Number of Sites - the number of sites that were accessed by the 
users, which form part of the category 

 Number of Users - the number of users that accessed the sites 
which form part of the category 

Table Sorting 

By default, the list is sorted by Bandwidth (DL) in descending order, 
but all columns can be sorted in either ascending or descending order 
by clicking on the appropriate column heading. 

Further Information 

Select the Web Category hyperlink to view the details for the web 
category. The information displayed includes: 

 Site - the site that was accessed by the users 

 User/IP - the user/IP that is being monitored 

 Bandwidth (DL/UL) - the total bandwidth used by each site 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user 
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3.7  Sites History 

The Sites History reports allows you to monitor total browsing times 
per site and the number of times a site was accessed. Two types of 
reports are available: 

 Top Time Consumption 

 Top Hits Count 

3.7.1 Top Time Consumption 

The Top Time Consumption report lists the sites on which network 
users spent most time browsing a site on a specific date. 

 
Screenshot 19 - Sites History: Top Time Consumption report 

Navigate to Monitoring ► Sites History ► Top Time Consumption 
to access the Top Time Consumption report. 

The information displayed includes: 

 Site - the site that was accessed by the users 

 Surf Time - the total time spent browsing each site 

 File Types - the total number of and the types of files accessed 
from each site followed by the number of times each file type was 
accessed in brackets 

 Accessed by User / IP - the total number and names/IP 
addresses of users/IP addresses that accessed the site 

Table Sorting 

By default, the list is sorted by Surf Time in descending order, but all 
columns apart from File Types and Accessed by User / IP can be 
sorted in either ascending or descending order by clicking on the 
appropriate column heading. 

Further Information 

Select the Site hyperlink to view the Site Access History. For more 
information, refer to the Site Access History section in this chapter. 

3.7.2 Top Hits Count 

The Top Hits Count report lists the sites that were most frequently 
accessed by network users on a specific date. 
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Screenshot 20 - Sites History: Top Hits Count report 

Navigate to Monitoring ► Sites History ► Top Hits Count to 
access the Top Hits Count report. 

The information displayed includes: 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Site - the site that was accessed by the users 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user 

 File Types - the total number of and the types of files accessed 
from each site followed by the number of times each file type was 
accessed in brackets 

 Accessed by User / IP - the total number and names/IP 
addresses of users/IP addresses that accessed the site 

Table Sorting 

By default, the list is sorted by Hits in descending order, but all 
columns apart from File Types and Accessed by User / IP can be 
sorted in either ascending or descending order by clicking on the 
appropriate column heading. 

Further Information 

Select the Site hyperlink to view the Site Access History. For more 
information, refer to the Site Access History section in this chapter. 

3.8  Users History 

The Users History reports allows you to monitor total browsing time 
per user, total number of times a user accesses sites and total number 
of policy violations per user. Three types of reports are available: 

 Top Surfers 

 Top Hits Count 

 Top Policy Breakers 

3.8.1 Top Surfers 

The Top Surfers report lists the time spent by network users browsing 
sites on a specific date. 
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Screenshot 21 - Users History: Top Surfers report 

Navigate to Monitoring ► Users History ► Top Surfers to access 
the Top Surfers report. 

The information displayed includes: 

 User/IP - the user/IP that is being monitored 

 Surf Time - the total time spent browsing each site 

 Sites Accessed - the total number and names of different sites 
accessed by the user 

Table Sorting 

By default, the list is sorted by Surf Time in descending order, but all 
columns apart from Sites Accessed can be sorted in either ascending 
or descending order by clicking on the appropriate column heading. 

Further Information 

Select the User/IP hyperlink to view the User History Details. For 
more information, refer to the User History Details section in this 
chapter. 

3.8.2 Top Hits Count 

The Top Hits Count report, lists the users with the highest number of 
site accesses on a specific date. 

 
Screenshot 22 - Users History: Top Hits Count report 

Navigate to Monitoring ► Users History ► Top Hits Count to 
access the Top Hits Count report. 

The information displayed includes: 
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 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 User/IP - the user/IP that is being monitored 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user 

 Sites Accessed - the total number and names of different sites 
accessed by the user 

Table Sorting 

By default, the list is sorted by Hits in descending order, but all 
columns apart from Sites Accessed can be sorted in either ascending 
or descending order by clicking on the appropriate column heading. 

Further Information 

Select the User/IP hyperlink to view the User History Details. For 
more information, refer to the User History Details section in this 
chapter. 

3.8.3 Top Policy Breakers 

The Top Policy Breakers report, lists the users with the highest 
number of policy violations on a specific date. 

 
Screenshot 23 - Users History: Top Policy Breakers report 

Navigate to Monitoring ► Users History ► Top Policy Breakers to 
access the Top Policy Breakers report. 

The information displayed includes: 

 User/IP - the user/IP that is being monitored and who violated the 
policy 

 Breaches - the number of policy violations by the user 

 Description - the category of the violated policy followed by the 
number of times the policy has been broken 

Table Sorting 

The list is sorted by User/IP in ascending order. 

Further Information 

Select the User/IP hyperlink to view the details for the user/IP 
address. The information displayed includes: 

 Time - the time the violation occurred 

 Description - the specific name of the violated policy 

 URL - the URL of the unauthorized site 
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 IP - the IP address that accessed the site 

3.9  Site Access History 

The Site Access History view graphically represents and lists details 
related to an accessed site on a specific date. 

 
Screenshot 24 - Site Access History view 

1. To access the Site Access History view: 

 Option 1: Navigate to Monitoring ► Bandwidth Consumption ► 
Top Sites to access the Top Sites report. 

 Option 2: Navigate to Monitoring ► Sites History ► Top Time 
Consumption to access the Top Time Consumption report. 

 Option 3: Navigate to Monitoring ► Sites History ► Top Hits 
Count to access the Top Hits Count report. 

2. Select the Site hyperlink. 

The information displayed includes: 

 Show Traffic Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 User/IP - the user/IP that is being monitored 

 Usage (DL/UL) - the total bandwidth used by each user. Hover on 
a specific value to view a Download/Upload Traffic over a 24-hour 
chart for a specific site, date and user. 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user. Hover on a specific value 
to view a Hits over a 24-hour chart for a specific site, date and 
user. 

 File Types - the types of files accessed by each user followed by 
the number of times the file type was accessed in brackets. Hover 
on a specific value (a site might have more than one file type value 
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listed) to view a Download/Upload Traffic over a 24-hour chart for 
a specific site, date and user. 

Table Sorting 

By default, the list is sorted by Hits in descending order, but all 
columns apart from File Types can be sorted in either ascending or 
descending order by clicking on the appropriate column heading. 

Further Information 

Select the User/IP hyperlink to view the User History Details. For 
more information, refer to the User History Details section in this 
chapter. 

3.10  User History Details 

The User History Details view graphically represents and lists details 
related to a monitored user/IP of a specific date. 

 
Screenshot 25 - User History Details view 

1. To access the User History Details view: 

 Option 1: Navigate to Monitoring ► Bandwidth Consumption ► 
Top Users to access the Top Users report. 

 Option 2: Navigate to Monitoring ► Users History ► Top 
Surfers to access the Top Surfers report. 
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 Option 3: Navigate to Monitoring ► Users History ► Top Hits 
Count to access the Top Hits Count report. 

2. Select the User/IP hyperlink. 

The information displayed includes: 

 Show Traffic Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Show Hits Over Time Chart - for more information, refer to the 
Charts section in this chapter. 

 Show IM Messages Over Time Chart - for more information, 
refer to the Charts section in this chapter. 

 Site - the site that was accessed by the users 

 Usage (DL/UL) - the total bandwidth used by each user. Hover on 
a specific value to view a Download/Upload Traffic over a 24-hour 
chart for a specific user, date and site. 

 Hits - the total number of requests (more than one request can be 
submitted for the same site) by the user. Hover on a specific value 
to view a Hits over a 24-hour chart for a specific user, date and 
site. 

 File Types - the types of files accessed by each user followed by 
the number of times the file type was accessed in brackets. Hover 
on a specific value (a site might have more than one file type value 
listed) to view a Download/Upload Traffic over a 24-hour chart for 
a specific user, date and site. 

 Web Category - the classification of which the accessed site 
forms part of 

Table Sorting 

By default, the list is sorted by Hits in descending order, but all 
columns apart from File Types can be sorted in either ascending or 
descending order by clicking on the appropriate column heading. 

Further Information 

Select the Site hyperlink to view the Site Access History. For more 
information, refer to the Site Access History section in this chapter. 

3.11  Activity Log 

The Activity Log report allows monitoring items that have been 
blocked or quarantined and processes that have failed on a specific 
date. 



24  Monitoring Internet activity GFI WebMonitor 2009 

 
Screenshot 26 - Activity Log view 

Navigate to Monitoring ► Activity Log to access the Activity Log 
view. 

The information displayed includes: 

 User - the user/IP that is being monitored 

 Time - the time the violation occurred 

 Description - the name of the violated policy 

 URL - the URL of the unauthorized site 

Table Sorting 

The list is sorted by Time in descending order. 

3.12  Viewing data by date 

By default, all reports within the Bandwidth Consumption, Sites 
History, Users History and Activity Log nodes list data for the 
current day (from midnight to the instant the report is launched). 

The displayed information is not refreshed automatically, as a result 
new data that becomes available after the generation of the current 
day report, is not displayed automatically. To update such data, click 

the refresh button  at the upper right corner of the view. 

To view data for other days, use the controls at the upper right of the 
view: 

 Previous day - click the back button . 

 Next day - click the forward button . 

 Specific date - click the calendar button , select the required 
date and click Go to retrieve data for that date. 

NOTE: If no data for a specific date is available (e.g. a future date is 
selected), an error message stating that data was unable to be 
retrieved is displayed. 

3.13  Charts 

Charts allow you to monitor statistics in an easier way. Three types of 
graphical representations are available: 

 Show Traffic Over Time Chart 

 Show Hits Over Time Charts 
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 Show IM Messages Over Time Chart 

Show Traffic Over Time Chart 

This chart allows you to view a graphical representation of the flow of 
total Download/Upload Traffic over a 24-hour period for a selected 
date. 

This chart also allows you to identify peaks in Download/Upload 
Traffic generated by the users. 

Show Hits Over Time Charts 

This chart allows you to view a graphical representation of the flow of 
total number of Hits over a 24-hour period for a selected date. 

This chart also allows you to identify peaks in the amount of requests 
by the users. 

Show IM Messages Over Time Chart 

This chart allows you to view a graphical representation of the flow of 
total number of Instant Messages over a 24-hour period for a selected 
date. 

This chart also allows you to identify peaks in the amount of Instant 
Messages sent/received by the users. 
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4 Allowing and blocking users, IP 
addresses and sites 

4.1  Introduction 

The Whitelist and Blacklist nodes enable you to set up content 
scanning policies that override all policy settings set up in WebFilter 
and WebSecurity editions. 

4.2  Whitelist 

The Whitelist is a list of sites, users and IP addresses approved by 
the administrator to be excluded from all policies configured in GFI 
WebMonitor. Besides the Permanent Whitelist, there is also a 
Temporary Whitelist that is used to temporarily approve access to a 
site for a user or IP address. 

IMPORTANT: In GFI WebMonitor, the Temporary Whitelist takes 
priority over the Permanent Whitelist. Furthermore, both Whitelists 
take priority over the Blacklist. Thus, if a site is listed in any of the 
Whitelists and that same site is listed in the Blacklist, the site will be 
allowed. 

4.2.1 Preconfigured items 

By default, GFI WebMonitor includes a number of preconfigured sites 
in the Permanent Whitelist. These include GFI websites to allow 
automatic updates to GFI WebMonitor and Microsoft websites to allow 
automatic updates to Windows. Removing any of these sites may 
preclude important updates from being automatically effected. 
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4.2.2 Adding items to the Permanent Whitelist 

 
Screenshot 27 - Permanent Whitelist view 

To add an item to the Permanent Whitelist: 

1. Navigate to the Whitelist node and select the Permanent Whitelist 
tab. 

2. From the drop-down list, select the User(s), Client IP(s) and/or 
Site(s) which will be added to the whitelist and click Add. Repeat for 
all the required user(s), IP(s) and/or site(s). 

NOTE: When adding a User to the whitelist, specify the username in 
the format DOMAIN\user. 

NOTE: When adding a Site to the whitelist, you can use wildcards 
(e.g. “*.website.com”). For more information, refer to the Using 
wildcards section in this chapter. 

3. Click Save Settings to finalize setup. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

4.2.3 Deleting items from the Permanent Whitelist 

To delete an item from the Permanent Whitelist: 

1. Navigate to the Whitelist node and select the Permanent Whitelist 
tab. 

2. Click the delete icon  next to the item you want to delete. 

3. Click Save Settings to complete deletion of whitelist items. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 
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4.2.4 Adding items to the Temporary Whitelist 

 
Screenshot 28 - Temporary Whitelist view 

To add an item to the Temporary Whitelist: 

1. Navigate to the Whitelist node and select the Temporary Whitelist 
tab. 

2. Click Add. 

 
Screenshot 29 - Temporary Whitelist: Granting Temporary Access dialog 

3. From the Grant to: drop-down list, select whether a User or an IP 
will be added to the temporary whitelist and provide the user or IP to 
be granted temporary access as well as the URL of the site and the 
number of hours. 

NOTE: When granting temporary access to a user, specify the 
username in the format DOMAIN\user. 

NOTE: When adding a Site to the whitelist, you can use wildcards 
(e.g. “*.website.com”). For more information, refer to the Using 
wildcards section in this chapter. 

4. Click Add to add the new item to the list. 
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5. Click Save Settings to finalize setup. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

NOTE: The number of hours during which the user or IP has access 
to a site become applicable from the moment Save Settings is 
clicked. 

NOTE: Time remaining before access is revoked can be viewed in the 
For (hours) column in the Temporary Whitelist view. 

4.2.5 Deleting items from the Temporary Whitelist 

To delete an item from the Temporary Whitelist: 

1. Navigate to the Whitelist node and select the Temporary Whitelist 
tab. 

2. Click the delete icon  next to the item you want to delete. 

3. Click Save Settings to complete deletion of whitelist items. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

4.3  Blacklist 

The Blacklist is a list of sites, users and IP addresses that should 
always be blocked irrespective of the WebFilter and WebSecurity 
policies configured in GFI WebMonitor. 

IMPORTANT: In GFI WebMonitor, the Blacklist takes priority over all 
WebFilter and WebSecurity policies. 

4.3.1 Adding items to the Blacklist 

 
Screenshot 30 - Blacklist view 

To add an item to the Blacklist: 

1. Navigate to the Blacklist node. 

2. From the drop-down list, select the User(s), Client IP(s) and/or 
Site(s) which will be added to the blacklist and click Add. Repeat for 
all the required user(s), IP(s) and/or site(s). 
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NOTE: When adding a User to the blacklist, specify the username in 
the format DOMAIN\user. 

NOTE: When adding a Site to the blacklist, you can use wildcards 
(e.g. “*.website.com”). For more information, refer to the Using 
wildcards section in this chapter. 

3. Click Save Settings to finalize setup. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

4.3.2 Deleting items from the Blacklist 

To delete an item from the Blacklist: 

1. Navigate to the Blacklist node. 

2. Click the delete icon  next to the item you want to delete. 

3. Click Save Settings to complete deletion of blacklist items. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

4.4  Using wildcards 

When adding a site to the whitelist or blacklist, you can use wildcards 
as shown in the examples below: 

Example Description 

*.com Allow/block all „.com‟ top-level domains 

*.website.com Allow/block all sub domains of the „website.com‟ domain 
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5 WebFilter Edition - Site rating and 
content filtering 

5.1  Introduction 

The WebFilter Edition node and its sub-nodes enable you to manage 
the Internet access of users, groups or IP addresses based on site 
categories together with the WebGrade database. 

The category of a particular site is determined through the WebGrade 
Database; if a site is listed in the database, GFI WebMonitor then 
uses the configured web filtering policies to determine what action to 
take. 

Policies can be customized to apply during specific periods. For 
example, a policy can enable users to access news and entertainment 
related sites during lunch breaks but not during working hours. 

Pre-defined site categories include pornography, adult themes, 
games, violence and others. The database is updated on a regular 
basis and updates are automatically downloaded to GFI WebMonitor. 

5.2  Web Filtering Policies 

The Web Filtering Policies node allows you to create policies per 
user(s), group(s) and/or IP(s) to manage Internet access during 
specific periods, based on web categories. If an accessed site file 
triggers a policy, GFI WebMonitor then uses the configured Virus 
Scanning policy to determine what action to take. This may be one of 
the following actions: 

 Allow access to sites within specified categories per user(s), 
group(s) and/or IP(s) 

 Block access to sites within specified categories per user(s), 
group(s) and/or IP(s) 

 Quarantine access to sites within specified categories per user(s), 
group(s) and/or IP(s); i.e. upon the discretion of the administrator 
temporary access is allowed to blocked sites 

 Exclude or Include specific sites per policy. 
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Screenshot 31 - Web Filtering Policies view 

5.2.1 Adding a Web Filtering Policy 

To add a Web Filtering Policy: 

1. Navigate to WebFilter Edition ► Web Filtering Policies. 

2. Click Add Policy. 

 
Screenshot 32 - Web Filtering Policies: General tab 
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3. Select the General tab. 

4. Provide a new policy name and description in the Policy Name field 
and the Policy Description text box respectively. 

5. In the Policy Schedule area, specify the time period(s) during 
which the new policy will be enforced. 

 
Screenshot 33 - Web Filtering Policies: Web Filtering tab 

6. Select the Web Filtering tab and define the categories applicable 
to the new policy and the actions to take: 

 Allow categories: Select categories from the Blocked Categories 
list and click Allow>. 

 Block categories: Select categories from the Allowed Categories 
list and click <Block. 

 Quarantine access: Select categories from the Allowed 
Categories list and click <Quarantine. 

NOTE: Advanced category conditions can also be configured by 
selecting the Show Advanced Options button. For more information, 
refer to the Configuring advanced Web Filtering Policy conditions 
section in this chapter. 
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Screenshot 34 - Web Filtering Policies: Exceptions tab 

7. Select the Exceptions tab and in the Excluded Sites and 
Included Sites fields specify any URLs, which are to be: 

 Excluded (i.e. allowed) from the policy. This enables users to 
access sites overriding any policy setup. 

 Included (i.e. blocked) in the new policy. The URLs specified in the 
included sites will be blocked regardless of the scope of the new 
policy. 

NOTE: The Exceptions tab is similar to a whitelist/blacklist feature 
that overrides any rules within the policy. 
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Screenshot 35 - Web Filtering Policies: Applies To tab 

8. Select the Applies To tab and specify the User(s), Group(s) and/or 
IP(s) for whom the new policy applies and click Add. Repeat for all the 
required user(s), group(s) and/or IP(s). 

NOTE: When adding a user, specify the username in the format 
DOMAIN\user. 

 
Screenshot 36 - Web Filtering Policies: Notifications tab 

9. (Optional) Select the Notifications tab and select the Notify the 
following administrators when the site category infringes this 
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policy checkbox to enable notification and define the administrator‟s 
notification email address and provide the body text of the notification 
email. 

10. (Optional) Select the Notify the user accessing the site if the 
site category infringes this policy checkbox to enable notification 
and provide the body text of the notification email. 

11. Click Save Settings to finalize creating a new policy. The new 
policy will now be listed in the main Web Filtering Policies view. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.2.2 Editing a Web Filtering Policy 

To edit a Web Filtering Policy: 

1. Navigate to WebFilter Edition ► Web Filtering Policies. 

2. Click the Edit icon  next to the policy you want to edit. 

NOTE: For more information, refer to the Adding a Web Filtering 
Policy section in this chapter. 

3. Click Save Settings to finalize editing a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.2.3 Enabling/disabling a Web Filtering Policy 

To enable or disable a Web Filtering Policy: 

1. Navigate to WebFilter Edition ► Web Filtering Policies. 

2. Check or uncheck the checkbox from the Enabled column for the 
policy you want to enable or disable. 

3. Click Save Settings to finalize enabling or disabling a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.2.4 Deleting a Web Filtering Policy 

To delete a Web Filtering Policy: 

1. Navigate to WebFilter Edition ► Web Filtering Policies . 

2. Click the delete icon  next to the policy you want to delete. 

3. Click Save Settings to finalize deleting a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.2.5 Default Web Filtering Policy 

GFI WebMonitor - WebFilter Edition ships with a default web filtering 
policy, which is configured to apply to all users. The policy name is 
listed as Default Web Filtering Policy. 

This policy can be edited but it cannot be disabled or deleted. Refer to 
the Editing a Web Filtering Policy section in this chapter for 
information related to editing web filtering policies. 
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IMPORTANT: All added Web Filtering Policies take priority over the 
Default Web Filtering Policy. 

NOTE: Certain fields in the default policy cannot be edited. These 
include Policy Name, Policy Description and fields in the Applies 
To tab. 

5.3  Configuring advanced Web Filtering Policy conditions 

The Override Rules area allows you to fine-tune combined actions 
and categories per policy. These advanced Web Filtering Policy 
conditions give you greater flexibility in defining which sites should be 
allowed or blocked. 

IMPORTANT: For a site to be blocked by an advanced condition, it 
must be listed under ALL categories defined in the condition. 

IMPORTANT: These advanced Web Filtering Policy conditions take 
priority over categories specified in the Allowed Categories and 
Blocked Categories list boxes. 

5.3.1 Adding an advanced Web Filtering Policy condition 

To add an advanced Web Filtering Policy condition: 

1. Select the Web Filtering tab and click Show Advanced Options to 
view the Override Rules for that specific policy. 

 
Screenshot 37 - Adding an advanced Web Filtering Policy condition 

2. Click the Add Condition button to view the Edit Properties dialog. 

3. Specify a combination of site categories that you would like to allow, 
block and quarantine or block and delete. 

For example, to block and delete sites which fall under the categories 
„Adult and Pornography‟ AND „Online Gambling‟: 

a. Select Adult and Pornography from Available Categories 
list box and click Use Category 

b. Select Online Gambling from Available Categories list box 
and click Use Category 

c. Select Block and Delete from the Perform this action: 
drop-down list and click OK to apply the condition. 
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In this example, a site is only blocked if it falls under both categories. 
Thus, it is NOT blocked if it is categorized as „Adult and Pornography‟ 
only and likewise it is NOT blocked if it is categorized as „Online 
Gambling‟ only. 

4. Click Save Settings to finalize creating an advanced condition for a 
policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.3.2 Editing an advanced Web Filtering Policy condition 

To edit an advanced Web Filtering Policy condition: 

1. Select the Web Filtering tab and click Show Advanced Options. 

2. Click the advanced policy to be edited, to view the Edit Properties 
dialog. 

3. Edit the advanced condition by doing any of the following: 

a. Add more or Remove categories 

b. Change the action from the Perform this action: drop-down 
list. 

4. Click OK to apply the changes you made. 

5. Click Save Settings to finalize editing an advanced condition for a 
policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.3.3 Deleting an advanced Web Filtering Policy condition 

To delete an advanced Web Filtering Policy condition: 

1. Select the Web Filtering tab and click Show Advanced Options. 

2. Click the delete icon  next to the advanced policy you want to 
delete. 

3. Click Save Settings to finalize deleting an advanced condition for a 
policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.4  WebGrade Database 

The WebGrade Database node allows you to: 

 Enable/disable the database 

 View the database status, version and license details 

 Enable/disable online lookups for URLs 

 Configure database updates 

 Check the presence or validity of any URL within the active local 
WebGrade database and send feedback. 
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Screenshot 38 - Web Filtering Policies: WebGrade Database view 

5.4.1 Enabling/disabling the WebGrade Database 

To enable or disable the WebGrade Database: 

1. Navigate to WebFilter Edition ► Web Filtering Policies ► 
WebGrade Database. 

2. Check or uncheck the checkbox from the Enabled column to 
enable or disable the database. 

NOTE: When the WebGrade Database is disabled, the Web Filtering 
Policies can no longer access the site categories. 

3. Click Save Settings to finalize enabling or disabling the database. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.4.2 Enabling/disabling online lookups for URLs 

To enable or disable online lookups for URLs: 

1. Navigate to WebFilter Edition ► Web Filtering Policies ► 
WebGrade Database. 

2. Check or uncheck the Enable online lookup for URLs not 
resolved by local database checkbox to enable or disable this 
feature. 

NOTE: This option is enabled by default when the user updates the 
installation. 

3. Click Save Settings to finalize enabling or disabling online lookups 
for URLs. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 
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5.4.3 Configuring WebGrade Database Updates 

The WebGrade Database Updates area allows you to: 

 Configure whether the WebGrade Database should be updated 
automatically or by manually clicking Update Now. 

 Configure the frequency with which available updates should be 
installed 

 Configure if an email notification should be sent upon successful 
updating of the WebGrade Database 

To configure settings for the WebGrade Database to update 
automatically: 

1. Navigate to WebFilter Edition ► Web Filtering Policies ► 
WebGrade Database. 

2. Check the Manage WebGrade Local Database updates 
automatically and update the time period within the hours field. 

3. Select the Send an email notification to the administrator on 
successfully updating the WebGrade Database checkbox if 
required. 

4. Click Save Settings to finalize configuration of settings for the 
WebGrade Database to update automatically. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

5.4.4 Checking URL Categories 

The Check URL Category area enables you to key in a URL and 
check for its category within your active local WebGrade database. If 
the category is not found or if the category listed in the local 
WebGrade database does not match with the website‟s category, you 
can report it for update. 

To find out the category of a URL: 

1. Navigate to WebFilter Edition ► Web Filtering Policies ► 
WebGrade Database. 

2. Key in URL in the check URL field 

3. Click Check URL Category. The category in the active local 
WebGrade database is displayed beneath the URL field. 

Reporting and/or suggesting URL categories 

To report and/or suggest a wrongly categorized / uncategorized URL: 

1. Click Submit Feedback. The WebGrade customer feedback 
form will be displayed in your browser. 

2. Fill in the form and click Submit. 
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6 WebSecurity Edition - File scanning 
and download control 

6.1  Introduction 

The WebSecurity Edition node and its sub-nodes enable you to scan 
and restrict usage for various applications to users, groups or IP 
addresses on your network. The control policies include: 

 Download Control Policies: to control software downloads 

 IM (Instant Messaging) Control Policies: to control access and 
use of MSN / Microsoft Windows Live Messenger 

 Virus Scanning Policies: to configure which downloaded files 
should be scanned for viruses and spyware 

 Anti-Phishing Engine: to configure protection settings for network 
users against phishing sites. 

6.2  Download Control Policies 

The Download Control Policies node allows you to create policies 
per user(s), group(s) and/or IP(s) to manage file downloads based on 
file types. If the download of a file triggers a policy, GFI WebMonitor 
then uses the configured Download Control policy to determine what 
action to take. This may be one of the following actions: 

 Allow the file to be downloaded by user(s), group(s) and/or IP(s) 

 Block the file from being downloaded by user(s), group(s) and/or 
IP(s) and quarantine the downloaded file 

 Block the file from being downloaded by user(s), group(s) and/or 
IP(s) and delete the downloaded file 

NOTE: For allowed downloads, GFI WebMonitor then applies the 
configured Virus Scanning Policies and determines its virus 
scanning options. 

 
Screenshot 39 - Download Control Policies view 

6.2.1 Adding a Download Control Policy 

To add a Download Control Policy: 

1. Navigate to WebSecurity Edition ► Download Control Policies. 



44  WebSecurity Edition - File scanning and download control GFI WebMonitor 2009 

2. Click Add Policy. 

 
Screenshot 40 - Download Control Policies: General tab 

3. Select the General tab. 

4. Key in a new policy name and description in the Policy Name field 
and the Policy Description text boxes respectively. 

 
Screenshot 41 - Download Control Policies: Download Control tab 
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5. Select the Download Control tab. 

 
Screenshot 42 - Adding a new content type dialog 

6. Click any File Type hyperlink from the list to display the Change 
Action dialog and configure the actions to be taken for that file type. 

7. From the Perform this action drop-down list select the applicable 
action to be taken. The available options are: 

 Allow 

 Block and Quarantine 

 Block and Delete 

8. Click OK to apply the action. 

9. (Optional) Click the Add Content-type button to create a new 
definition. For more information, refer to the Adding New Content-
types section in this chapter. 

 
Screenshot 43 - Download Control Policies: Applies To tab 
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10. Select the Applies To tab and specify the User(s), Group(s) 
and/or IP(s) for whom the new policy applies and click Add. Repeat 
for all the required user(s), group(s) and/or IP(s). 

NOTE: When adding a user, specify the username in the format 
DOMAIN\user. 

 
Screenshot 44 - Download Control Policies: Notifications tab 

11. (Optional) Select the Notifications tab and select the Notify the 
following administrators when the downloaded content infringes 
this policy checkbox to enable notification and define the 
administrator‟s notification email address and provide the body text of 
the notification email. 

12. (Optional) Select the Notify the user performing the download 
when the downloaded content infringes this policy checkbox to 
enable notification and provide the body text of the notification email. 

13. Click Save Settings to finalize creating a new policy. The new 
policy will now be listed in the main Download Control Policies view. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.2.2 Editing a Download Control Policy 

To edit a Download Control Policy: 

1. Navigate to WebSecurity Edition ► Download Control Policies. 

2. Click the Edit icon  next to the policy you want to edit. 
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NOTE: For more information, refer to the Adding a Download Control 
Policy section in this chapter. 

3. Click Save Settings to finalize editing a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.2.3 Enabling/disabling a Download Control Policy 

To enable or disable a Download Control Policy: 

1. Navigate to WebSecurity Edition ► Download Control Policies. 

2. Check or uncheck the checkbox from the Enabled column for the 
policy you want to enable or disable. 

3. Click Save Settings to finalize enabling or disabling a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.2.4 Deleting a Download Control Policy 

To delete a Download Control Policy: 

1. Navigate to WebSecurity Edition ► Download Control Policies. 

2. Click the delete icon  next to the policy you want to delete. 

3. Click Save Settings to finalize deleting a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.2.5 Default Download Control Policy 

GFI WebMonitor - WebSecurity Edition ships with a default download 
control policy, which is configured to apply to all users. The policy 
name is listed as Default Download Control Policy. 

This policy can be edited but it cannot be disabled or deleted. Refer to 
the Editing a Download Control Policy section in this chapter for 
information related to editing download control policies. 

IMPORTANT: All added Download Control Policies take priority over 
the Default Download Control Policy. 

NOTE: Certain fields in the default policy cannot be edited. These 
include Policy Name, Policy Description and fields in the Applies 
To tab. 

6.2.6 Adding New Content-types 

The New Content-type dialog allows you to create new definitions for 
file types, which are not yet in the predefined list. 
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Screenshot 45 - Add new content type dialog 

To create a new content-type: 

1. Select the Download Control tab and click Add Content-type to 
view the New Content-type dialog. 

2. Key in the content-type in the Content-Type field in the format 
type/subtype. 

3. (Optional) Provide a description for the file type in the Description 
field. 

4. Click Add. 

5. Click Save Settings to finalize creating a new content-type. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.3  IM (Instant Messaging) Control Policies 

The IM (Instant Messaging) Control Policies node allows you to 
create policies per user(s), group(s) and/or IP(s) to control the use of 
MSN Messenger and Microsoft Windows Live Messenger. If the usage 
of a file triggers a policy, GFI WebMonitor then uses the configured IM 
Control policy to determine what action to take. This may be one of 
the following actions: 

 Blocking all traffic related to MSN / Windows Live Messenger 

 Allowing all traffic related to MSN / Windows Live Messenger 

 
Screenshot 46 - IM Control Policies view 

6.3.1 Adding an IM Control Policy 

To add an IM Control Policy: 
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1. Navigate to WebSecurity Edition ► IM Control Policies. 

2. Click Add Policy. 

 
Screenshot 47 - IM Control Policies: General tab 

3. Select the General tab. 

4. Provide a new policy name and description in the Policy Name field 
and the Policy Description text box respectively. 

 
Screenshot 48 - IM Control Policies: IM Control tab 

5. Select the IM Control tab and define the actions to take. The 
available options are: 

 Block All MSN / Windows Live Messenger traffic 

 Allow MSN / Windows Live Messenger traffic 
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Screenshot 49 - IM Control Policies: Applies To tab 

6. Select the Applies To tab and specify the User(s), Group(s) and/or 
IP(s) for whom the new policy applies and click Add. Repeat for all the 
required user(s), group(s) and/or IP(s). 

NOTE: When adding a user, specify the username in the format 
DOMAIN\user. 
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Screenshot 50 - IM Control Policies: Notifications tab 

7. (Optional) Select the Notifications tab and select the Notify the 
following administrators when this IM policy is breached 
checkbox to enable notification and define the administrator‟s 
notification email address and provide the body text of the notification 
email. 

8. (Optional) Select the Notify the user breaching this IM policy 
checkbox to enable notification and provide the body text of the 
notification email. 

9. Click Save Settings to finalize creating a new policy. The new 
policy will now be listed in the main IM Control Policies view. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.3.2 Editing an IM Control Policy 

To edit an IM Control Policy: 

1. Navigate to WebSecurity Edition ► IM Control Policies. 

2. Click the Edit icon  next to the policy you want to edit. 

NOTE: For more information, refer to the Adding an IM Control Policy 
section in this chapter. 
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3. Click Save Settings to finalize editing a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.3.3 Enabling/Disabling an IM Control Policy 

To enable or disable an IM Control Policy: 

1. Navigate to WebSecurity Edition ► IM Control Policies. 

2. Check or uncheck the checkbox from the Enabled column for the 
policy you want to enable or disable. 

3. Click Save Settings to finalize enabling or disabling a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.3.4 Deleting an IM Control Policy 

To delete an IM Control Policy: 

1. Navigate to WebSecurity Edition ► IM Control Policies. 

2. Click the delete icon  next to the policy you want to delete. 

3. Click Save Settings to finalize deleting a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.3.5 Default IM Control Policy 

GFI WebMonitor - WebSecurity Edition ships with a default instant 
messaging control policy, which is configured to apply to all users. The 
policy name is listed as Default IM Control Policy. 

This policy can be edited but it cannot be disabled or deleted. Refer to 
the Editing an IM Control Policy section in this chapter for information 
related to editing download control policies. 

IMPORTANT: All added IM Control Policies take priority over the 
Default IM Control Policy. 

NOTE: Certain fields in the default policy cannot be edited. These 
include Policy Name, Policy Description and fields in the Applies 
To tab. 

6.4  Virus Scanning Policies 

The Virus Scanning Policies node allows you to create policies per 
user(s), group(s) and/or IP(s) to manage virus scanning of files based 
on file types. If the download of an infected file triggers a policy, GFI 
WebMonitor then uses the configured Virus Scanning policy to 
determine what action to take. This may be one of the following 
actions: 

 Issue a warning, but still Allow the file to be downloaded by 
user(s), group(s) and/or IP(s) 

 Block the file from being downloaded by user(s), group(s) and/or 
IP(s) and quarantine the downloaded file 

 Block the file from being downloaded by user(s), group(s) and/or 
IP(s) and delete the downloaded file 
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GFI WebMonitor scans the downloaded files with any of the supported 
virus scanners. On the user‟s machine, GFI WebMonitor displays the 
download progress, the virus scanning status and progress as well as 
the results. 

 
Screenshot 51 - Virus Scanning Policies view 

6.4.1 Adding a Virus Scanning Policy 

To add a Virus Scanning Policy: 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies. 

2. Click Add Policy. 

 
Screenshot 52 - Virus Scanning Policies: General tab 

3. Click the General tab. 

4. Provide new policy name and description in the Policy Name field 
and the Policy Description text box respectively. 
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Screenshot 53 - Virus Scanning Policies: Virus Scanning tab 

5. Select the Virus Scanning tab. 

6. Click any File Type hyperlink from the list to display the Select 
Virus Scanners and Action dialog and configure the actions to be 
taken for that file type. 

7. From the If a virus is found perform this action: drop-down list 
select the applicable action to be taken. The available options are: 

 Warn and Allow 

 Block and Quarantine 

 Block and Delete 

8. Click OK to apply the action. 

9. (Optional) Click the Add Content-type button to create a new 
definition. For more information, refer to the Adding New Content-
types section in this chapter. 
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Screenshot 54 - Virus Scanning Policies: Applies To tab 

10. Select the Applies To tab and specify the User(s), Group(s) 
and/or IP(s) for whom the new policy applies and click Add. Repeat 
for all the required user(s), group(s) and/or IP(s). 

NOTE: When adding a user, specify the username in the format 
DOMAIN\user. 

 
Screenshot 55 - Virus Scanning Policies: Notifications tab 



56  WebSecurity Edition - File scanning and download control GFI WebMonitor 2009 

11. (Optional) Select the Notifications tab and select the Notify the 
following administrators when the downloaded content infringes 
this policy checkbox to enable notification and define the 
administrator‟s notification email address and provide the body text of 
the notification email. 

12. (Optional) Select the Notify the user performing the download 
when the downloaded content infringes this policy checkbox to 
enable notification and provide the body text of the notification email. 

13. Click Save Settings to finalize creating a new policy. The new 
policy will now be listed in the main Virus Scanning Policies view. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.4.2 Editing a Virus Scanning Policy 

To edit a Virus Scanning Policy: 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies. 

2. Click the Edit icon  next to the policy you want to edit. 

NOTE: For more information, refer to the Adding a Virus Scanning 
Policy section in this chapter. 

3. Click Save Settings to finalize editing a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.4.3 Enabling/disabling a Virus Scanning Policy 

To enable or disable a Virus Scanning Policy: 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies. 

2. Check or uncheck the checkbox from the Enabled column for the 
policy you want to enable or disable. 

3. Click Save Settings to finalize enabling or disabling a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.4.4 Deleting a Virus Scanning Policy 

To delete a Virus Scanning Policy: 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies. 

2. Click the delete icon  next to the policy you want to delete. 

3. Click Save Settings to finalize deleting a policy. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.4.5 Default Virus Scanning Policy 

GFI WebMonitor WebSecurity Edition ships with a default virus 
scanning policy, which is configured to apply to all users. The policy 
name is listed as Default Virus Scanning Policy. 



GFI WebMonitor 2009 WebSecurity Edition - File scanning and download control  57 

This policy can be edited but it cannot be disabled or deleted. Refer to 
the Editing a Virus Scanning Policy section in this chapter for 
information related to editing virus-scanning policies. 

IMPORTANT: All added Virus Scanning Policies take priority over the 
Default Virus Scanning Policy. 

NOTE: Certain fields in the default policy cannot be edited. These 
include Policy Name, Policy Description and fields in the Applies 
To tab. 

6.4.6 Adding New Content-types 

The New Content-type dialog allows you create new definitions for 
file types, which are not yet in the predefined list. 

 
Screenshot 56 - Add new content type dialog 

To create a new content-type: 

1. Select the Virus Scanning tab and click Add Content-type to view 
the New Content-type dialog. 

2. Key in the content-type in the Content-Type field in the format 
type/subtype. 

3. (Optional) Provide a description for the file type in the Description 
field. 

4. Click Add. 

5. Click Save Settings to finalize creating a new content-type. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.5  Virus & Spyware Protection 

The Virus & Spyware Protection node allows you to: 

 Enable or disable one or more of the supported anti-virus scanning 
engines 

 View the anti-virus scanning engine status, version and license 
details 

 Configure anti-virus updates for each of the anti-virus scanning 
engines 



58  WebSecurity Edition - File scanning and download control GFI WebMonitor 2009 

 
Screenshot 57 - Virus & Spyware Protection view 

6.5.1 Enabling/disabling the scanning engines 

To enable or disable one or more of the anti-virus scanning engines: 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies ► 
Virus & Spyware Protection. 

2. Check or uncheck the checkbox from the Enabled column to 
enable or disable a scanning engine. 

NOTE: When an anti-virus scanning engine is disabled, GFI 
WebMonitor can no longer scan files using that disabled engine. 

3. Click Save Settings to finalize enabling or disabling a virus-
scanning engine. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.5.2 Configuring Anti-Virus Updates 

The Anti-Virus Updates area for each one of the supported anti-virus 
scanning engines allows you to: 

 Configure whether the scanning engine should be updated 
automatically or by manually clicking Update Now 

 Configure the frequency with which available updates should be 
installed 

 Configure if an email notification should be sent upon successful 
updating of the scanning engine 

 
Screenshot 58 - BitDefender Anti-Virus view 
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Screenshot 59 - Norman Anti-Virus view 

To configure settings for any of the anti-virus scanning engines to 
update automatically: 

1. Navigate to: 

 Option 1: WebSecurity Edition ► Virus Scanning Policies ► 

Virus & Spyware Protection and click the Edit icon  next to 
the anti-virus scanning engine you want to edit. 

 Option 2: WebSecurity Edition ► Virus Scanning Policies ► 
Virus & Spyware Protection and select the anti-virus scanning 
engine from BitDefender, Kaspersky or Norman. 

2. Check the Manage anti-virus updates automatically and update 
the time period within the hours field. 

3. Select the Send an email notification to the administrator on 
successfully updating the anti-virus checkbox if required. 

4. Click Save Settings to finalize configuration of settings for the 
selected anti-virus scanning engine to update automatically. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

Configuring Kaspersky Virus-Scanning Engine Options 

The Kaspersky anti-virus scanning engine allows you to state 
whether the actions specified in the Virus Scanning Policies should 
also be used when files are identified as: 

 Suspicious 

 Corrupted (i.e. files that cannot be scanned since the file format is 
corrupted, for example, corrupted CAB files) 

 Hidden (i.e. files that cannot be scanned since the contents are 
protected, for example, password protected ZIP files) 
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Screenshot 60 - Kaspersky Anti-Virus view 

1. Navigate to WebSecurity Edition ► Virus Scanning Policies ► 
Virus & Spyware Protection ► Kaspersky Anti-Virus. 

2. Check or uncheck the Suspicious, Corrupted or Hidden 
checkboxes to enable or disable the relevant Virus Scanning 
Policies actions for files identified as Suspicious, Corrupted or 
Hidden. 

3. Click Save Settings to finalize configuration of settings for the 
Kaspersky anti-virus scanning engine. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.6  Anti-Phishing Engine 

The Anti-Phishing Engine node allows you to: 

 Enable or disable anti-phishing monitoring 

 View the anti-phishing database status, version and license details 

 Configure anti-phishing database updates 

6.6.1 Enabling/disabling the Anti-Phishing Engine 

To enable or disable the Anti-Phishing Engine: 

1. Navigate to WebSecurity Edition ► Anti-Phishing Engine. 
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Screenshot 61 - Anti-Phishing Engine: General tab 

2. Click the General tab. 

3. Check or uncheck the Block access to phishing sites checkbox 
to enable or disable anti-phishing features. 

NOTE: When the anti-phishing engine is disabled, GFI WebMonitor 
can no longer block phishing sites. 

4. Click Save Settings to finalize enabling or disabling the anti-
phishing engine. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.6.2 Configuring Anti-Phishing database updates 

The Anti-Phishing Updates area allows you to: 

 Configure whether the anti-phishing engine should be updated 
automatically or by manually clicking Update Now 

 Configure the frequency with which available updates should be 
installed 

 Configure if an email notification should be sent upon successful 
updating of the anti-phishing engine 

To configure settings for the anti-phishing engine to update 
automatically: 

1. Navigate to WebSecurity Edition ► Anti-Phishing Engine. 

2. Click the General tab. 

3. Check the Manage anti-phishing updates automatically and 
update the time period within the hours field. 

4. Select the Send an email notification to the administrator on 
successfully updating the anti-phishing checkbox if required. 

5. Click Save Settings to finalize configuration of settings for the anti-
phishing engine to update automatically. 
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NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

6.6.3 Configuring phishing notifications 

The Notifications tab in Anti-Phishing Engine node allows you to 
specify whether email notifications are to be sent to administrators and 
/ or to users when an accessed site is identified as a phishing site. 

To configure phishing notifications: 

1. Navigate to WebSecurity Edition ► Anti-Phishing Engine. 

 
Screenshot 62 - Anti-Phishing Engine: Notifications tab 

2. (Optional) Select the Notifications tab and select the Notify the 
following administrators when the site accessed is a known 
phishing site checkbox to enable notification and define the 
administrator‟s notification email address and provide the body text of 
the notification email. 

3. (Optional) Select the Notify the user accessing the site if the site 
accessed is a known phishing site checkbox to enable notification 
and provide the body text of the notification email. 

4. Click Save Settings to finalize configuring phishing notifications. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 
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7 Configuring GFI WebMonitor 

7.1  Introduction 

The Configuration node and its sub-nodes enable you to configure a 
default set of parameters used by the WebFilter and WebSecurity 
editions. The configuration parameters include: 

 Administrative Access Control: to configure who can access 
GFI WebMonitor web interface for configuration and monitoring 

 Notifications: to configure alerting options for email notifications 
on important events and licensing 

 General Settings: to configure the data retention, downloaded 
cache, temporary whitelist policies and number of records to be 
displayed per page. 

 Proxy settings: Configure GFI WebMonitor proxy settings 

 Reporting: Configure the database settings for reporting. 

7.2  Administrative Access Control 

The Administrative Access Control node allows you to list the 
user(s) and IP(s), which are allowed to access the GFI WebMonitor 
application (i.e. by keying in the URL http://monitor.isa in their web 
browser) from their machine. Specified users are allowed access to 
GFI WebMonitor only if their username has been authenticated. 

7.2.1 Adding Users/IP addresses to the access 
permissions list 

 
Screenshot 63 - Configuration: Administrative Access Control view 

To add a user and/or IP to the access permissions list: 

1. Navigate to Configuration ► Administrative Access Control. 

2. Specify the User(s) and/or IP(s), whom are allowed to access the 
GFI WebMonitor application from their machine and click, Add. 
Repeat for all the required user(s), group(s) and/or IP(s). 

http://monitor.isa/
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NOTE: When adding a user, specify the username in the format 
DOMAIN\user. 

3. Click Save Settings to finalize adding users and/or IP addresses to 
the access permissions list. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.2.2 Deleting Users/IP addresses from the access 
permissions list 

To delete a user and/or IP from the access permissions list: 

1. Navigate to Configuration ► Administrative Access Control. 

2. Click the delete icon  next to the user/IP you want to delete. 

3. Click Save Settings to finalize deleting users/IP addresses. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.3  Notifications 

The Notifications node allows you to specify from where and to 
whom are important administrative notifications sent. Such emails are 
sent on important events including: 

 Items being blocked or quarantined 

 WebGrade Database and/or anti-virus signature update failures 

 WebGrade Database and/or anti-virus signature update success 

 Approaching expiry of WebGrade Database and/or to update anti-
virus signature licenses. 

7.3.1 Configuring the sender of administrative notifications 

To configure the sender: 

1. Navigate to Configuration ► Notifications. 

2. In the Send administrative emails using the following settings 
area, key in the sender‟s email address, the SMTP server and SMTP 
port. 

3. Click Save Settings to finalize configuring the sender. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 
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7.3.2 Configuring the recipients of administrative 
notifications 

 
Screenshot 64 - Configuration: Notifications view 

To add recipients to whom notifications are sent: 

1. Navigate to Configuration ► Notifications. 

2. In the Email Address field specify the email address(es) of the 
recipient(s) and click Add. Repeat for all the required recipients. 

3. Click Save Settings to finalize adding recipients. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.3.3 Deleting email recipients 

To delete recipients to whom notifications are sent: 

1. Navigate to Configuration ► Notifications. 

2. Click the delete icon  next to the email address you want to 
delete. 

3. Click Save Settings to finalize deleting recipients. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.4  General Settings 

The General Settings node allows you to configure several generic 
settings. The settings include: 
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 The number of days to keep browsing related data in the database 

 The number of hours to keep downloaded files in the cache 

 The number of hours a site is kept in the temporary whitelist after it 
has been approved from the quarantine 

 The language in which messages are displayed on the user‟s 
machine. 

To configure general settings for GFI WebMonitor: 

1. Navigate to Configuration ► General Settings. 

 
Screenshot 65 - Configuration: General Settings view - Data Retention 

2. In the Data Retention area, specify for how long (in days) browsing 
activity data will be kept in the GFI WebMonitor databases. This data 
is used for monitoring and reporting. 

 
Screenshot 66 - Configuration: General Settings view - Download Cache 

3. In the Download Cache area, specify for how long (in hours) 
downloaded files will be kept in a local cache. Keeping these files in 
the cache will speed up subsequent requests for the same file. 

 
Screenshot 67 - Configuration: General Settings view - Temporary Whitelist 

4. In the Temporary Whitelist area, specify for how long (in hours) 
items approved from the quarantine will be kept in the Temporary 
Whitelist. This is the amount of time available to the user, during which 
the approved URL is accessible. 

NOTE: To disable the Temporary Whitelist set the value to zero hours. 
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Screenshot 68 - Configuration: General Settings view – Statistics: Records per Page 

5. In the Statistics: Records per Page area, specify the number of 
records to be displayed per page (default 500 records per page) for 
every report located under the Monitoring node. 

NOTE: This setting does not apply for the Top Categories report. 

 
Screenshot 69 - Configuration: General Settings view - Language 

6. In the Language area, select the language from drop-down list, in 
which GFI WebMonitor displays messages on the user‟s machines. 
Messages from GFI WebMonitor include: 

 Download status windows 

 Blocking Notifications 

7. Click Save Settings to finalize configuring general settings for GFI 
WebMonitor. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.5  Proxy Settings 

The Proxy Settings node allows you to configure several proxy 
settings. The settings include: 

 Network Configuration 

 Authentication Method 

 Chained Proxy 

NOTE: This node is only available in GFI WebMonitor Standalone 
Proxy version. 
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Screenshot 70 - Configuration: Proxy Settings view 

7.5.1 Configuring Network Configuration 

The Network Configuration area allows you to configure GFI 
WebMonitor to listen for incoming connections on a specific network 
card. The Network Configuration drop-down list contains a list of 
network cards installed on GFI WebMonitor machine. 

To configure on which network interface GFI WebMonitor will listen to 
incoming connections: 

1. Navigate to Configuration ► Proxy Settings. 
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Screenshot 71 - Configuration: Proxy Settings view - Network Configuration 

2. Select the IP address of the network card (through which the proxy 
listens to incoming connections) from the drop-down list, and key in 
the listening port (default 8080). 

3. Select the Use WPAD for network clients to allow client machines 
to detect the server as the default proxy. 

4. Select: 

 Option 1: Publish the IP of the GFI WebMonitor proxy in WPAD 
checkbox to include the GFI WebMonitor IP address in the 
WPAD.dat file. 

 Option 2: Publish the host name of the GFI WebMonitor proxy 
in WPAD checkbox to include the GFI WebMonitor host name in 
the WPAD.dat file. 

5. Click Save Settings to finalize configuring on which network 
interface GFI WebMonitor will listen to incoming connections. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

NOTE: Select the Listen on all network interfaces checkbox if the 
GFI WebMonitor server is required to listen to incoming connections 
on multiple network cards. 

7.5.2 Configuring Authentication Method 

The Authentication Method area allows you to configure the 
authentication method used by the proxy. This determines how client 
machines are validated when accessing the Internet. 

 
Screenshot 72 - Configuration: Proxy Settings view - Authentication method 

No authentication 

Select this checkbox if proxy authentication is not required. Thus, the 
user is not required to key in a valid username and password when 
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launching a new Internet session. When launched, the Internet 
browser will not prompt the user to provide valid login credentials. 

Basic authentication 

Select this checkbox if the user is required to key in a valid username 
and password when launching a new Internet session. When 
launched, the Internet browser will prompt the user to provide valid 
login credentials. 

Integrated authentication 

Select this checkbox if proxy authentication is required. This is done 
using the client machines‟ access control service. Users will not be 
required to key in login credentials to access the Internet. 
(Recommended) 

The Integrated authentication option is disabled on machines where 
Local users are authenticated as guest (This policy is enabled by 
default on a Microsoft Windows XP Pro machine which has never 
been joined to a Domain Controller). Network access method can be 
configured: 

 Manually on each machine or, 

 Using Active Directory GPO. 

For more information, refer to the Configuring Network Access policy 
section in the Miscellaneous chapter. 

Exception List 

The Set Exception List button allows you to specify the IP addresses 
that GFI WebMonitor will exempt from proxy authentication. 

To add IP addresses: 

1. Click the Set Exception List button. 

  
Screenshot 73 - Exception list dialog 

2. In the IP field, specify the IP that is to be excluded and click Add. 
Repeat for all the required IP addresses. 

3. Click OK to exit the dialog. 

4. Click Save Settings to finalize adding IP addresses. 



GFI WebMonitor 2009 Configuring GFI WebMonitor  71 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.5.3 Configuring Chained Proxy 

The Chained Proxy area allows you to configure the forwarding of 
HTTP traffic received by the GFI WebMonitor machine to another 
proxy. 

NOTE: Client machines have to be configured to forward HTTP traffic 
received by them to the GFI WebMonitor machine. 

To configure GFI WebMonitor to forward HTTP traffic to a proxy 
server: 

1. Navigate to Configuration ► Proxy Settings. 

 
Screenshot 74 - Configuration: Proxy Settings view - Chained Proxy 

2. Select the WebMonitor Proxy will route the web traffic to the 
following proxy: checkbox. 

3. Key in the proxy server IP address in the Address text box and key 
in the chained proxy‟s port (default 8080) in the Port text box. 

4. If proxy authentication requires alternate credentials, key in the 
required credentials in the Username and Password fields. 

NOTE: If no credentials are keyed in, the default user credentials are 
used. 

5. (Optional) Click the Test Proxy Chaining button to test the 
connection between the GFI WebMonitor machine and the proxy 
server. 

6. Click Save Settings to finalize configuring GFI WebMonitor to 
forward HTTP traffic to a proxy server. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.6  Reporting 

The Reporting node allows you to store data on an existing database 
for statistical information. Use GFI WebMonitor ReportPack to view 
and analyze stored information. In this section, you will find 
information about: 

 Reporting requirements 

 How to enable or disable information gathering 

 Configuring reporting options. 
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7.6.1 Reporting requirements 

Before enabling reporting, create a blank database in an SQL 
environment. On enabling reporting, the database structure is 
automatically configured by GFI WebMonitor. 

Creating a new database in Microsoft SQL Server 2008 

1. On the SQL server machine, navigate to Start ► All Programs ► 
Microsoft SQL Server 2008 ► SQL Server Management Studio. 

2. Key in the database administrator credentials. 

3. From the left panel expand SQL Server node ► Security. 

 
Screenshot 75 - Create new SQL login 

4. Right-click Logins and select New Login. 

5. Key in a valid user login name (example webMon_user). 

6. Select the authentication type and click OK to apply changes. 

7. From the left panel right-click Databases folder and select New 
Database. 

8. In the new database dialog, key in a valid name (for example 
WEBMONDB). 

9. Click the Owner browse (…) button to select the user created 
earlier from the Select Database Owner dialog. 

10. Click Browse. 
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Screenshot 76 - Browse for Objects dialog 

11. Select the user created earlier and click OK. 

12. Click OK to close the Select Database Owner dialog and OK in 
the New Database dialog to apply changes. 

NOTE: To view more information on how to create a new database on 
various Microsoft SQL Server versions, refer to KBase article: 
http://kbase.gfi.com/showarticle.asp?id=KBID003379 

7.6.2 Enable Reporting 

To enable information gathering for reporting purposes: 

1. Navigate to Configuration ► Reporting. 

http://kbase.gfi.com/showarticle.asp?id=KBID003379
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Screenshot 77 - Configuration: Reporting view 

2. Check the Enable Reporting checkbox to enable reporting feature. 

3. Key in the SQL Server, the User/Password combination and the 
Database name that enables GFI WebMonitor to connect and audit 
data to the database in the respective order. 

NOTE: To retrieve the list of available databases, click the Get 
Database List button. 

4. Click Save Settings to finalize enabling information gathering for 
reporting purposes. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

NOTE: For security purposes, passwords can only be keyed in from 
the machine where GFI WebMonitor is installed. Thus, users who are 
allowed Administrative Access Control from their machine will not be 
able to view the list of available databases. 

7.6.3 Disabling Reporting 

To disable information gathering for reporting purposes: 

1. Navigate to Configuration ► Reporting. 

2. Uncheck the Enable Reporting checkbox to disable reporting 
feature. 
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3. Click Save Settings to finalize disabling information gathering for 
reporting purposes. 

NOTE: Failing to click Save Settings means that you will lose settings 
as soon as you leave the view to move to another section in GFI 
WebMonitor. 

7.6.4 Updating Reporting Data 

Daily at midnight, GFI WebMonitor automatically transfers any logged 
data to the Microsoft SQL Server backend database (the same 
database configured when enabling the reporting feature). There are 
instances however when the data retrieval process needs to be 
triggered manually, such as: 

 When upgrading the version of GFI WebMonitor 

 When migrating data stored in files in a storage location to a 
central database 

 To test configuration settings. 

In these cases and others, click the Update Reporting Data Now 
button to trigger the transfer process. 

NOTE: Data is always collected for complete 24-hour periods from 
midnight to midnight. Thus, the Update Reporting Data Now feature 
does not collect data for partial periods, example between midnight 
and the time when this button is clicked. 
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8 Quarantine 

8.1  Introduction 

The Quarantine node and its sub-nodes enable you to view 
quarantined items categorized according to the policy they triggered, 
as well as allow you to either approve or delete the quarantined items. 
An item can be: 

 an unauthorized site, 

 an unauthorized downloaded file, or 

 a virus infected downloaded file. 

The following GFI WebMonitor policies can be set to quarantine these 
items: 

 Web Filtering Policies 

 Download Control Policies 

 Virus Scanning Policies 

GFI WebMonitor does not store the downloaded files, but it stores 
their respective URL, same as for the unauthorized sites. 

Administrators should review the quarantine to: 

 Establish the reason for which an item is being quarantined 

 Determine whether the item is unauthorized/harmful or not 

 Determine whether the item should be approved or not. 

If approved from the quarantine list, quarantined items are transferred 
to the Temporary Whitelist and can then be accessed on a 
temporary basis by the user who triggered the policy. 

If deleted from the quarantine list, only the entry is deleted and thus, 
the items will continue be quarantined by the respective policies. 

Users can again be forbidden access to the items through the 
Temporary Whitelist feature. For more information, refer to the 
Deleting items from the Temporary Whitelist section in the Allowing 
and blocking users, IP addresses and sites chapter. 

There are four different views for quarantined items: 

 Today - displays all items transferred to quarantine today 

 Yesterday - displays all items transferred to quarantine yesterday 

 This Week - displays all items transferred to quarantine on the last 
7 days starting from today 

 All Items - displays all items currently in quarantine 

8.2  Viewing quarantined items 

The Today, Yesterday, This Week and All Items lists display all 
items quarantined during the specified periods and categorized 
according to the policy they triggered. 
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Screenshot 78 - Quarantine view 

To view quarantined items: 

1. Navigate to the Quarantine node, and select one of the views 
available to view either all the quarantined items or just those for a 
specified period: 

 Today 

 Yesterday 

 This Week 

 All Items 

2. Click the required policy tab to view a list of items quarantined for 
each respective policy category: 

 Download Control Policies tab 

 Web Filtering Policies tab 

 Virus Scanning Policies tab 

3. Click the details icon  to view specific details for that item. 

4. Click Go Back To List to move back to the list of quarantined 
items. 

5. Use the navigation icons  to navigate through long 
lists of quarantined items. 

The information displayed includes: 

 Quarantined On - the date and time the item was quarantined 
upon violation of policy 

 User/IP - the user/IP that is being monitored and who violated the 
policy 

 Download URL - the URL of the downloaded file or of the 
unauthorized site 

 Quarantine Reason - the reason why the item was quarantined 

Table Sorting 

The lists are sorted by Quarantined On in descending order. 
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8.3  Approving quarantined items 

The Today, Yesterday, This Week and All Items lists allow you to 
approve any of the quarantined items. Thus, users are allowed 
temporary access to these items that are transferred to the Temporary 
Whitelist. 

To approve one or more items in quarantine: 

1. Navigate to the Quarantine node, and select one of the views 
available, depending on when the item was quarantined. 

2. Click the policy tab where the quarantined items are listed. 

 
Screenshot 79 - Quarantined item details view 

3. To make the downloaded files or accessed URLs available to users: 

 Option 1: Click the details icon  to view specific details for an 
item and click the Approve Item button. 

 Option 2: Select the checkboxes of individual items and click the 
Approve Selected Item(s) button. 

 Option 3: Click the Approve All Items button. 

NOTE: For more information, refer to the Allowing and blocking users, 
IP addresses and sites chapter in this manual. 

NOTE: Exert extreme caution with this feature. By approving an item 
from the Quarantine, you are excluding the website from all policies 
configured in GFI WebMonitor for that particular user. Approving a 
potentially harmful file may therefore lead to your network being 
compromised. 

NOTE: The user email address is shown only if the user has been 
authenticated, and has a valid Active Directory email field. 

8.4  Deleting quarantined items 

The Today, Yesterday, This Week and All Items lists allow you to 
delete any of the entries of the quarantined items. Thus, users are not 
allowed to access these items and further attempts will still be 
quarantined by the respective policies. 

To delete one or more items in quarantine: 

1. Navigate to the Quarantine node, and select one of the views 
available, depending on when the item was quarantined. 

2. Click the policy tab where the quarantined items are listed. 
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3. To delete the items‟ entries: 

 Option 1: Click the details icon  to view specific details for an 
item and click the Delete Item button. 

 Option 2: Select the checkboxes of individual items and click the 
Delete Selected Item(s) button. 

 Option 3: Click the Delete All Items button. 
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9 Miscellaneous 

9.1  Introduction 

The miscellaneous chapter gathers all the other information that falls 
outside the initial configuration of GFI WebMonitor. 

9.2  Configuring Network Access policy 

In the Configuration ► Proxy Settings area, the Integrated 
authentication option is disabled on GFI WebMonitor machines 
where the Network access setting is set to Guest only - local users 
authenticate as Guest. On a Microsoft Windows XP Pro machine 
that has never been joined to a Domain Controller, this setting is set 
by default. 

The Network access setting can be configured on each GFI 
WebMonitor machine: 

 Manually or, 

 Using Active Directory GPO. 

Configuring network access manually 

To configure Network access setting on a GFI WebMonitor machine 
manually: 

1. Navigate to Start ► Control Panel ► Administrative Tools ► 
Local Security Policy. 

2. Expand Security Settings ► Local Policies ► Security Options. 

3. Right-click Network access: Sharing and security model for 
local accounts from the right panel and click Properties. 
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Screenshot 80 - Microsoft Windows XP: Local Security Settings tab 

4. Select the Local Security Setting tab. 

5. Select Classic - local users authenticate as themselves from the 
Network access drop-down list. 

6. Click Apply and OK. 

7. Close Local Security Settings dialog. 

8. Close all open windows. 

Configuring network access using GPO in Microsoft Windows 
Server 2003  

To configure Network access setting on GFI WebMonitor machines 
through Microsoft Windows Server 2003 GPO: 

1. Navigate to Start ► Programs ► Administrative Tools ► Active 
Directory Users and Computers on the DNS server. 

2. Right-click the domain node and click Properties. 
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Screenshot 81 - Active Directory GPO dialog 

3. Select Group Policy tab in the Domain Properties dialog. 

4. Select Default Domain Policy from the list and click Edit. 

5. Expand Computer Configuration ► Windows Settings ► 
Security Settings ► Local Policies and click Security Options. 

6. Right-click Network access: Sharing and security model for 
local accounts from the right panel and click Properties. 

7. In the Security Policy Setting tab, check Define this policy 
setting checkbox. 

8. Select Classic - local users authenticate as themselves from the 
Network access drop-down list. 

9. Click Apply and OK. 

10. Close all open windows. 

Configuring network access using GPO in Microsoft Windows 
Server 2008  

To configure Network access setting on GFI WebMonitor machines 
through Microsoft Windows Server 2008 GPO: 

1. In the command prompt key in mmc.exe and press Enter. 

2. In the Console Root window navigate to File ► Add/Remove 
Snap-in… to open the Add or Remove Snap-ins window. 
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Screenshot 82 - Add/Remove Snap-ins window 

3. Select Group Policy Management from the Available snap-ins 
list, and click Add. 

4. Click OK. 

 
Screenshot 83 - Console Root domain window 

5. Expand Group Policy Management ► Forest ► Domains and 
Domain. 

6. Right-click Default Domain Policy and click Edit. This opens the 
Group Policy Management Editor. 

7. Expand Computer Configuration ► Policies ► Windows 
Settings ► Security Settings ► Local Policies and click Security 
Options. 

8. Right-click Network access: Sharing and security model for 
local accounts from the right panel and click Properties. 
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9. In the Security Policy Setting tab, check Define this policy 
setting checkbox. 

10. Select Classic - local users authenticate as themselves from 
the Network access drop-down list. 

11. Click Apply and OK. 

12. Close Group Policy Management Editor dialog and save the 
management console created. 

This information is also available in KBase article: 

http://kbase.gfi.com/showarticle.asp?id=KBID003666 

 

http://kbase.gfi.com/showarticle.asp?id=KBID003666
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10 Troubleshooting 

10.1  Introduction 

The troubleshooting chapter explains how you should go about 
resolving any software issues that you might encounter. The main 
sources of information available to users are: 

 The manual - most issues can be solved by reading this manual 

 GFI Knowledge Base articles 

 Web forum 

 Contacting GFI Technical Support 

10.2  Common Issues 
Issue encountered  Solution 

Users are not able to 
browse and/or 
download from the 
Internet after installing 
GFI WebMonitor as a 
standalone proxy 
version. 

After the installation, GFI WebMonitor proxy machine 
has to be configured to listen for incoming connections. 
For more information, refer to the Proxy Settings 
chapter in this manual. 

Next, Internet browsers on client machines have to be 
configured to use the GFI WebMonitor proxy machine 
as the default proxy. 

In the event that the users are still not able to browse 
and/or download from the Internet, add an exception 
rule in the firewall on the GFI WebMonitor proxy 
machine to allow incoming TCP traffic on port 8080. 

Client browsers are still 
retrieving old proxy 
Internet settings 
although the browsers 
are configured to 
automatically detect 
settings. 

Internet explorer may not refresh cached Internet 
settings so client browsers will retrieve old Internet 
settings. Refreshing settings is a manual process on 
each client browser. 

For more information, refer to the Refresh cached 
Internet Explorer settings section within the 
Miscellaneous chapter in GFI WebMonitor Getting 
Started Guide. 

Or visit: 

http://technet.microsoft.com/en-
us/library/cc302643.aspx 

Users are still required 
to authenticate 
themselves manually 
when browsing, even 
when Integrated 
authentication is used. 

Integrated authentication will fail when GFI WebMonitor 
is installed on a Microsoft Windows XP Pro machine 
that has never been joined to a Domain Controller and 
where the Network access setting is set to Guest only 
- local users authenticate as Guest. For more 

information, refer to the Configuring Network Access 
policy section in the Miscellaneous chapter. 

Users using Mozilla 
Firefox browsers are 
repeatedly asked to key 
in credentials after 
installing GFI 
WebMonitor as a 
standalone proxy 
version. 

The server and the client machine will use NTLMv2 for 
authentication when: 

 GFI WebMonitor is installed on Microsoft Windows 
Server 2008 and LAN Manager authentication 
security policy is defined as Send NTLMv2 
response only 

and 

 The client machine LAN Manager is not defined 
(this is the default setting in Microsoft Windows 7) 
NTLMv2 is not supported in Mozilla Firefox and the 
user„s browser will repeatedly ask for credentials. 

http://technet.microsoft.com/en-us/library/cc302643.aspx
http://technet.microsoft.com/en-us/library/cc302643.aspx
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To solve this issue do one of the following : 

1. Navigate to Configuration ► Proxy Settings. 

2. In the Network Configuration area select the Use 
WPAD for network clients checkbox. 

3. Select Publish the host name of the GFI 
WebMonitor proxy in WPAD. 

 

Or change authentication mechanism on either of the 
following: 

 

On GFI WebMonitor server (Microsoft Windows 
Server 2008): 

1. Navigate to Start ► Administrative Tools ► Local 
Security Policy. 

2. Expand Local Policies ► Security Options. 

3. Right-click Network Security: LAN Manager 
authentication level from the right panel and click 
Properties. 

4. Select Local Security Setting tab in the Network 
Security: LAN Manager authentication level 
Properties dialog. 

5. Select Send LM & NTLM - use NTLMv2 session 
security if negotiated from the Network security drop-

down list. 

6. Click Apply and OK. 

7. Close Local Security Policy dialog. 

8. Close all open windows. 

 

Client machines (Microsoft Windows 7) using 
Active Directory GPO: 

1. Navigate to Start ► Control Panel ► System and 
Security ► Administrative Tools ► Local Security 
Policy. 

2. Expand Local Policies ► Security Options. 

3. Right-click Network Security: LAN Manager 
authentication level from the right panel and click 
Properties. 

4. Select Local Security Setting tab in the Network 
Security: LAN Manager authentication level 
Properties dialog. 

5. Select Send LM & NTLM - use NTLMv2 session 
security if negotiated from the Network security drop-
down list. 

6. Click Apply and OK. 

7. Close Local Security Policy dialog. 

8. Close all open windows. 

For more information visit: 

http://kbase.gfi.com/showarticle.asp?id=KBID001782 

10.3  Knowledge Base 

GFI maintains a Knowledge Base, which includes answers to the most 
common problems. If you have a problem, please consult the 
Knowledge Base first. The Knowledge Base always has the most up-
to-date listing of technical support questions and patches. To access 
the Knowledge Base, visit http://kbase.gfi.com/. 

10.4  Web Forum 

User to user technical support is available via the web forum. The 
forum can be found at http://forums.gfi.com/. 

http://kbase.gfi.com/showarticle.asp?id=KBID001782
http://kbase.gfi.com/
http://forums.gfi.com/
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10.5  Request technical support 

If you have referred to this manual and our Knowledge Base articles, 
and you still cannot solve issues with the software, contact the GFI 
Technical Support team by filling in an online support request form or 
by phone. 

 Online: Fill out the support request form on: 
http://support.gfi.com/supportrequestform.asp. Follow the 
instructions on this page closely to submit your support request. 

 Phone: To obtain the correct technical support phone number for 
your region please visit http://www.gfi.com/company/contact.htm. 

NOTE: Before you contact our Technical Support team, please have 
your Customer ID available. Your Customer ID is the online account 
number that is assigned to you when you first register your license 
keys in our Customer Area at https://customers.gfi.com/login.aspx. 

We will answer your query within 24 hours or less, depending on your 
time zone. 

10.6  Build notifications 

We recommend that you subscribe to our build notifications list. This 
way, you will be immediately notified about new product builds. To 
subscribe to our build notifications, 

visit: http://www.gfi.com/pages/productmailing.htm 

 

http://support.gfi.com/supportrequestform.asp
http://www.gfi.com/company/contact.htm
https://customers.gfi.com/login.aspx
http://www.gfi.com/pages/productmailing.htm
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11 Glossary 

Access Control A feature that allows or denies users access to 
resources. For example, Internet access. 

Active Directory A technology that provides a variety of network 
services, including LDAP-like directory services. 

AD See Active Directory 

Administrator The person responsible for installing and configuring 
GFI WebMonitor. 

Anti-virus Software that detects viruses on a computer. 

Bandwidth The maximum amount of data transferred over a 
medium. Typically measured in bits per second. 

Blacklist A list that contains information about what should be 
blocked by GFI WebMonitor. 

Chained Proxy When client machines connect to more than one 
proxy server before accessing the requested 
destination. 

Console An interface that provides administration tools that 
enable the monitoring and management of Internet 
traffic. 

Dashboard Enables the user to obtain graphical and statistical 
information related to GFI WebMonitor operations. 

File Transfer Protocol A protocol used to transfer files between computers. 

FTP See File Transfer Protocol. 

Google Chrome A web browser developed and distributed by Google. 

GPO See Group Policy Objects. 

Group Policy Objects An Active Directory centralized management and 
configuration system that controls what users can and 
cannot do on a computer network. 

Hidden Downloads Unwanted downloads from hidden applications 
(trojans, etc.) or forgotten downloads initiated by 
users. 

HTTP See Hypertext Transfer Protocol. 

HyperText Transfer 
Protocol 

A protocol used to transfer hypertext data between 
servers and Internet browsers. 

Internet Browser An application installed on a client machine that is 
used to access the Internet. 

Internet Gateway A computer that has both an internal and an external 
network card. Internet sharing is enabled, and client 
machines on the internal network use this computer 
to access the Internet. 

Microsoft Forefront 
Threat Management 
Gateway 

A Microsoft product that provides firewall and web 
proxy services. It also enables administrators to 
manage Internet access through policies. It is the 
successor of the Microsoft ISA Server and is part of 
the Microsoft Forefront line of business security 
software. 

Microsoft Forefront 
TMG 

See Microsoft Forefront Threat Management 
Gateway 

Microsoft Internet 
Explorer 

A web browser developed and distributed by 
Microsoft Corporation. 
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Microsoft Internet 
Security and 
Acceleration Server 

A Microsoft product that provides firewall and web 
proxy services. It also enables administrators to 
manage Internet access through policies. 

Microsoft ISA Server See Microsoft Internet Security and Acceleration 
Server. 

Microsoft SQL Server A Microsoft database management system used by 
GFI WebMonitor to store and retrieve data. 

Microsoft Windows 
Live Messenger 

An instant messaging application developed by 
Microsoft used by users to communicate on the 
Internet. 

LAN See Local Area Network. 

LDAP See Lightweight Directory Access Protocol. 

Lightweight Directory 
Access Protocol 

A set of open protocols for accessing directory 
information such as email addresses and public keys. 

Local Area Network An internal network that connects machines in a small 
area. 

MSN See Microsoft Windows Live Messenger 

Malware Short for malicious software. 

Unwanted software designed to infect a computer 
such as a virus or a trojan. 

Mozilla Firefox Mozilla Firefox is an open source Internet browser. 

NTLM See NT LAN Manager. 

NT LAN Manager A Microsoft network authentication protocol. 

Phishing The act of collecting personal data such as credit 
card and bank account numbers by sending fake 
emails which then direct users to sites asking for such 
information. 

Port Blocking The act of blocking or allowing traffic over specific 
ports through a router. 

Proxy Server A server or software application that receives 
requests from client machines and responds 
according to filtering policies configured in GFI 
WebMonitor. 

Quarantine A temporary storage for unknown data that awaits 
approval from an administrator. 

Spyware Unwanted software that publishes private information 
to an external source. 

Traffic Forwarding The act of forwarding internal/external network traffic 
to a specific server through a router. 

Uniform Resource 
Locator 

The address of a web page on the world wide web. It 
contains information about the location and the 
protocol. 

URL See Uniform Resource Locator. 

User Agent A client application that connects to the Internet and 
performs automatic actions. 

Virus Unwanted software that infects a computer. 

WAN See Wide Area Network. 

Web Proxy 
AutoDiscovery 
protocol 

An Internet protocol used by browsers to retrieve 
automatically proxy settings from a WPAD data file. 

Web traffic The data sent and received by clients over the 
network to websites. 

WebFilter Edition A configurable database that allows site access 
according to specified site categories per 
user/group/IP address and time. 

WebGrade Database A database in GFI WebMonitor, used to categorize 
sites. 
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WebSecurity Edition WebSecurity contains multiple anti-virus engines to 
scan web traffic accessed and downloaded by the 
clients. 

Whitelist A list that contains information about what should be 
allowed by GFI WebMonitor. 

Wide Area Network An external network that connects machines in large 
areas. 

WPAD See Web Proxy AutoDiscovery protocol. 
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